Paypal is currently experiencing some issues on their end, payment method is heavily affected by this outage.

Incident Report for Qliro Service

Resolved

This incident has been resolved.
Posted Jun 02, 2025 - 20:51 CEST

Investigating

We are currently investigating this issue.
Posted Jun 02, 2025 - 20:26 CEST
This incident affected: Payment Methods (PayPal).