Swish payment method is down
Incident Report for Qliro Service
Resolved
Swish is up. We are monitoring
Posted Nov 27, 2023 - 11:03 CET
Investigating
Swish has disturbances.
Posted Nov 27, 2023 - 09:31 CET
This incident affected: Payment Methods (Swish).