Payment Method Trustly is down

Incident Report for Qliro Service

Resolved

This incident has been resolved.
Posted Jul 04, 2024 - 11:01 CEST

Investigating

Payment Method Trustly is down
Posted Jul 04, 2024 - 09:14 CEST
This incident affected: Payment Methods (Trustly).