Swish having issues
Incident Report for Qliro Service
Resolved
This incident has been resolved.
Posted Jun 29, 2023 - 20:08 CEST
Investigating
Swish is having issues. Swish payment method temporarily disabled.
Posted Jun 29, 2023 - 18:20 CEST
This incident affected: Payment Methods (Swish).