Partial outage around Paypal
Incident Report for Qliro Service
Resolved
This incident have now been resolved by Paypal.
Posted Nov 10, 2022 - 10:06 CET
Identified
We have identified that Paypal are currently experiencing issues around their services, resulting in a partial outage around the payment method.
Posted Nov 10, 2022 - 08:40 CET
This incident affected: Payment Methods (PayPal).