Swish is experiencing issues.

Incident Report for Qliro Service

Resolved

This incident has been resolved.
Posted May 06, 2025 - 22:40 CEST

Update

We are continuing to investigate this issue.
Posted May 06, 2025 - 17:27 CEST

Update

We are continuing to investigate this issue.
Posted May 06, 2025 - 17:18 CEST

Investigating

Swish is reporting disruptions to service.
Posted May 06, 2025 - 17:17 CEST
This incident affected: Payment Methods (Swish).