Trustly payments
Incident Report for Qliro Service
Resolved
The incident has been resolved.
Posted Sep 28, 2023 - 16:38 CEST
Investigating
We are currently experiencing issues with Trustly payments in Qliro Checkout. We are working to restore the service as soon as possible. Thank you for your patience.
Posted Sep 28, 2023 - 15:17 CEST
This incident affected: Payment Methods (Trustly).