Slow response times in the checkout

Incident Report for Qliro Service

Resolved

This incident has been resolved.
Posted Jan 24, 2023 - 16:39 CET

Investigating

We are currently investigating this issue.
Posted Jan 24, 2023 - 14:48 CET
This incident affected: Qliro One checkout.