Trustly having issues
Incident Report for Qliro Service
Resolved
Incident resolved, Trustly fully operational again.
Posted Aug 24, 2023 - 08:13 CEST
Investigating
We are currently experiencing issues with Trustly payments in Qliro Checkout. We are working to restore the service as soon as possible. Thank you for your patience.
Posted Aug 24, 2023 - 07:45 CEST
This incident affected: Payment Methods (Trustly).