Payment Method Swish is down

Incident Report for Qliro Service

Resolved

This incident has been resolved.
Posted 8 days ago. Mar 24, 2025 - 11:02 CET

Investigating

Swish has a major disturbance.
Posted 8 days ago. Mar 24, 2025 - 10:45 CET
This incident affected: Payment Methods (Swish).