PayPal outage
Incident Report for Qliro Service
Resolved
The service disruption issues that were affecting the Paypal payment option were resolved by Paypal during the early morning hours.
The payment option is now fully operational again.
Posted Sep 05, 2022 - 07:53 CEST
Identified
We have confirmed that Paypal is currently having a service disruption around their Payflow link, and that they are
currently investigating the issue.
Posted Sep 04, 2022 - 21:30 CEST
This incident affected: Payment Methods (PayPal).