Slowness in Qliro's Consumer App. Savings functionality temporarily unavailable in Qliro's Consumer App.

Incident Report for Qliro Service

Resolved

This incident has been resolved.
Posted Mar 16, 2025 - 10:49 CET

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 16, 2025 - 10:42 CET

Investigating

Qliro's App is currently experiencing longer load times, and our savings products are temporarily unavailable in the Qliro App. We are actively investigating the issue.
Posted Mar 16, 2025 - 10:11 CET