Payment Method PayPal is down
Incident Report for Qliro Service
Resolved
This incident has been resolved.
Posted Nov 21, 2024 - 15:32 CET
Update
We are continuing to investigate this issue.
Posted Nov 21, 2024 - 15:31 CET
Investigating
Payment Method PayPal is down.
Posted Nov 21, 2024 - 12:53 CET
This incident affected: Payment Methods (PayPal).