Issues around Trustly payment option

Incident Report for Qliro Service

Resolved

The fix from Trustly have been confirmed to resolve the issue. Everything is now back to normal and being fully operational.
Posted Feb 16, 2023 - 20:07 CET

Monitoring

A fix has been implemented by Trustly and we are monitoring the results.
Posted Feb 16, 2023 - 20:01 CET

Update

Trustly have informed that they have now identified the issue and are working on resolving this with the highest priority.
We will be informed as soon as the problem is resolved so that we can revert the disablement as soon as possible.
Posted Feb 16, 2023 - 19:34 CET

Identified

We are communicating with Trustly regarding their issues, and have temporarily disabled the payment method until
we can confirm that the problems are resolved.
Posted Feb 16, 2023 - 19:24 CET

Investigating

We are currently investigating this issue.
Posted Feb 16, 2023 - 19:05 CET
This incident affected: Payment Methods (Trustly).