Payment Method Cards has degraded performance
Incident Report for Qliro Service
Resolved
This incident has been resolved.
Posted Feb 21, 2024 - 23:05 CET
Update
Some card issuers has issues to prompt authentication which blocks the payment.
Posted Feb 21, 2024 - 16:00 CET
Update
Nordea card holders has issues finalize payments. We have notified vendors and are monitoring
Posted Feb 21, 2024 - 14:13 CET
Investigating
Payment Method with Card has degraded performance. We are investigating
Posted Feb 21, 2024 - 12:38 CET
This incident affected: Payment Methods (Card payments).