Swish have confirmed they are currently experiencing operational disruptions with Swedbank

Incident Report for Qliro Service

Resolved

This incident has been resolved.
Posted Jan 31, 2026 - 17:00 CET

Investigating

We are currently investigating this issue.
Posted Jan 31, 2026 - 15:56 CET
This incident affected: Payment Methods (Swish).