Payment method Swish is down

Incident Report for Qliro Service

Resolved

This incident has been resolved.
Posted Apr 15, 2025 - 22:10 CEST

Investigating

Swish payment method is down. We have disabled the payment method
Posted Apr 15, 2025 - 20:48 CEST
This incident affected: Payment Methods (Swish).