Paypal partial outage
Incident Report for Qliro Service
Resolved
The service disruption issues that were affecting the Paypal payment option are now resolved by Paypal.
Posted Sep 05, 2022 - 14:58 CEST
Identified
We have confirmed that Paypal is yet again experiencing service disruption around their Payflow link, and that they are
currently investigating the issue.
Posted Sep 05, 2022 - 12:25 CEST
This incident affected: Payment Methods (PayPal).