Payment Method Swish has disturbances

Incident Report for Qliro Service

Resolved

This incident has been resolved.
Posted Apr 08, 2025 - 06:10 CEST

Investigating

We are currently investigating this issue.
Posted Apr 07, 2025 - 21:28 CEST
This incident affected: Payment Methods (Swish).