Trustly down
Incident Report for Qliro Service
Resolved
This incident has been resolved.
Posted Sep 15, 2023 - 10:00 CEST
Investigating
We are currently experiencing issues with Trustly payments in Qliro Checkout. We are working to restore the service as soon as possible. Thank you for your patience.
Posted Sep 14, 2023 - 22:06 CEST
This incident affected: Payment Methods (Trustly).