We are currently experiencing a service disruption at third party. Our external provider/supplier is investigating the issue. Thank you for your patience.

Incident Report for Qliro Service

Resolved

This incident has been resolved.
Posted Jul 19, 2025 - 22:45 CEST

Update

We are continuing to investigate this issue.
Posted Jul 19, 2025 - 22:44 CEST

Update

We are continuing to investigate this issue.
Posted Jul 19, 2025 - 19:59 CEST

Investigating

We are currently investigating this issue.
Posted Jul 19, 2025 - 19:54 CEST
This incident affected: Payment Methods (Card payments).