Payment Method Swish has technical disturbances
Incident Report for Qliro Service
Resolved
This incident has been resolved.
Posted Jan 11, 2024 - 15:34 CET
Investigating
Swish has technical disturbances and we are monitoring
Posted Jan 11, 2024 - 15:13 CET
This incident affected: Payment Methods (Swish).