Trustly PayOn integration issues
Incident Report for Qliro Service
Resolved
Trustly is now re-enabled for all Merchants.
Posted Jun 01, 2023 - 16:58 CEST
Investigating
We currently have an issue with Trustly and have disabled this payment method. The recently released Trustly Express is not affected and is fully operational.
Posted May 31, 2023 - 15:34 CEST
This incident affected: Payment Methods (Trustly).