Some MerchantWeb functions currently unavailable
Incident Report for Qliro Service
Resolved
This incident has been resolved.
Posted Jul 19, 2024 - 15:20 CEST
Investigating
Order data is partially unavailable for Nordic countries. Extend due date and download invoice functionalities are down.
Posted Jul 19, 2024 - 11:24 CEST
This incident affected: Merchant Operation (Qliro MerchantWeb).