Merchant web search functionality is slow
Incident Report for Qliro Service
Resolved
This incident has been resolved.
Posted May 10, 2022 - 09:00 CEST
Investigating
We are currently investigating this issue.
Posted May 10, 2022 - 08:41 CEST
This incident affected: Merchant Operation (Qliro MerchantWeb).