Our payment provider has confirmed issues affecting credit cards

Incident Report for Qliro Service

Resolved

This incident has been resolved.
Posted Mar 21, 2026 - 00:48 CET

Investigating

We are currently investigating this issue.
Posted Mar 20, 2026 - 23:53 CET