Swish have confirmed they are currently experiencing operational disruptions with Nordea

Incident Report for Qliro Service

Resolved

This incident has been resolved.
Posted Feb 27, 2026 - 10:09 CET

Investigating

We are currently investigating this issue.
Posted Feb 27, 2026 - 09:23 CET
This incident affected: Payment Methods (Swish).