Payment Method Swish has disturbances

Incident Report for Qliro Service

Resolved

This incident has been resolved.
Posted Apr 09, 2025 - 20:51 CEST

Investigating

We are currently investigating this issue.
Posted Apr 09, 2025 - 20:47 CEST
This incident affected: Payment Methods (Swish).