Issues with Card payments

Incident Report for Qliro Service

Resolved

This incident has been resolved.
Posted Nov 30, 2022 - 12:08 CET

Investigating

We are currently investigating this issue.
Posted Nov 30, 2022 - 10:31 CET
This incident affected: Payment Methods (Card payments).