Issues with BankID are affecting pay-later products.

Incident Report for Qliro Service

Resolved

This incident has been resolved.
Posted Apr 15, 2025 - 15:32 CEST

Monitoring

The issue has been resolved and we are currently monitoring the situation to ensure stability.
Posted Apr 15, 2025 - 15:02 CEST

Investigating

We are currently investigating this issue.
Posted Apr 15, 2025 - 14:46 CEST
This incident affected: Payment Methods (Qliro Pay After Delivery).