Payment Method Swish is down

Incident Report for Qliro Service

Resolved

This incident has been resolved.
Posted May 15, 2025 - 21:27 CEST

Investigating

Payment Methods Swish is down
Posted May 15, 2025 - 20:28 CEST
This incident affected: Payment Methods (Swish).